Update 2.0.2.0

Announcements / News about BitCloud

Moderator: Core Team

Post Reply
User avatar
luk
Core Team
Posts: 35
Joined: Fri Jun 01, 2018 6:50 am
Has thanked: 7 times
Been thanked: 4 times

#1

Thu Jun 21, 2018 6:43 am

Hi together,

we released a new BitCloud update version 2.0.2.0 which is mandatory, because we had some issue with governance system & superblock that is fixed in this update.

Release notes:
This update increases the minimum protocol version. It also changes the time of the next superblock. This update is mandatory.
But this is not the only change in this Update, we have updated our Wallet design finally ;) We hope you like it, every feedback is welcome!
You can get the new update here -> https://github.com/LIMXTEC/Bitcloud/releases/tag/2.0.2.0


To update your masternode you have the following options:

1. Use update script
Login to your VPS via SSH and follow this steps:

Code: Select all

wget https://raw.githubusercontent.com/c1xx/BitCloud-mn-install/master/btdx-mn-update.sh
chmod +x btdx-mn-update.sh
./btdx-mn-update.sh
2. Update your docker container
Login to your VPS via SSH and follow this steps:

Code: Select all

docker exec -it btdx-masternode bash
supervisorctl stop bitcloudd
cd /usr/local/bin/
wget https://github.com/LIMXTEC/Bitcloud/releases/download/2.0.2.0/linux.Ubuntu.16.04.LTS-static-libstdc.tar.gz
tar -xzvf linux.Ubuntu.16.04.LTS-static-libstdc.tar.gz
rm linux.Ubuntu.16.04.LTS-static-libstdc.tar.gz
supervisorctl start bitcloudd
sudo su bitcloud
bitcloud-cli getinfo
After executing last command you should get output like this:

Code: Select all

bitcloud@01dc0121ad80:/$ bitcloud-cli getinfo
{
    "version" : 2000200,
    "protocolversion" : 70714,
    "walletversion" : 61000,
    "balance" : 0.00000000,
    "Darksend_balance" : 0.00000000,
    "blocks" : 87607,
    "timeoffset" : 0,
    "connections" : 48,
    "proxy" : "",
    "difficulty" : 231480.29988366,
    "testnet" : false,
    "keypoololdest" : 1529400323,
    "keypoolsize" : 1001,
    "paytxfee" : 0.00000000,
    "relayfee" : 0.00010000,
    "staking status" : "Staking Not Active",
    "errors" : ""
}
Check if version and protocolversion equals with this versions:

Code: Select all

"version" : 2000200
"protocolversion" : 70714
If you have any issues or questions feel free to contact us.
These users thanked the author luk for the post:
quasarbeast (Wed Jun 27, 2018 11:06 am)
User avatar
roadcrypto
Team
Posts: 6
Joined: Wed Jun 06, 2018 3:13 am
Has thanked: 1 time
Been thanked: 4 times

#2

Fri Jun 22, 2018 3:48 am

when running the masternode update script, it's possible that there are old versions causing problems.
if you ran the commands:
and you're still on version 200100

you can:
ls
to see if there's other files in your working directory:

Image

if all you have in there are .sh and .tar.gz files, you can:
rm *
this will remove all the old files.
there will be an error saying the directory wasn't deleted and that's ok.

now, run the wget again:
that's it.
These users thanked the author roadcrypto for the post (total 3):
Brad (Fri Jun 22, 2018 4:09 am) • luk (Fri Jun 22, 2018 4:12 am) • quasarbeast (Wed Jun 27, 2018 11:06 am)
Post Reply